Installer flash 32 sur un systeme 64 : Différence entre versions

De ArchwikiFR
m (Robot : Enlève modèles : I18n, Lang, Stub, Translateme)
Ligne 1 : Ligne 1 :
{{i18n|Install 32bit Flash on a 64bit System}}
+
 
  
 
Comment installer le plugin Flash d'Adobe sur Arch64.
 
Comment installer le plugin Flash d'Adobe sur Arch64.
Ligne 43 : Ligne 43 :
 
[[Catégorie:Arch64]]
 
[[Catégorie:Arch64]]
 
[[Catégorie:Howto]]
 
[[Catégorie:Howto]]
 +
[[Category:Necessite relecture]]

Version du 18 mars 2011 à 20:32


Comment installer le plugin Flash d'Adobe sur Arch64.

Support natif du 64 bits

Suite à un problème de sécurité, le plugin Flash 64-bits officiel d'Adobe n'existe plus [1]. L'ancienne version (qui pose des problèmes de sécurité, donc) est encore disponible sur AUR flashplugin-native64.

Utilisation du plugin 32 bits

Le plugin Flash 32 bits peut être utilisé dans un navigateur 64 bits par l'intermédiaire d'un petit logiciel nspluginwrapper. Celui-ci est maintenant disponible dans le dépôt [multilib]. Pour l'utiliser, ajoutez les lignes

[multilib]
Include = /etc/pacman.d/mirrorlist

à votre fichier pacman.conf. Le plugin est contenu dans le paquet flashplugin

# pacman -S flashplugin

Celui-ci installe automatiquement nspluginwrapper.

Nspluginwrapper et Konqueror

Vous devez ajouter le répertoire /usr/lib/mozilla/plugins à l'outil de recherche de plugin de Konqueror.

Nsplugins 32 bits avec Konqueror 64 bits

Il est possible d'utiliser la version 32 bits de nspluginviewer (et nspluginscan) avec konqueror, ce qui est plus performant et stable que l'utilisation du wrapper. La version 64 bits de Java et kMplayer ne seront pas affecté car ils ne sont pas traités comme des plugins par Konqueror.

Opera 9.50

Opera 9.50 contient un wrapper 32 bits donc aucune chose comme nsplugin n'est requise. Installez simplement les dépendances listé précédement et ensuite faites les étapes suivantes.

# cp libflashplayer.so /usr/lib/opera/plugins

Ou installez flashplayer-opera64 depuis AUR.